Quick Edit Bug

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Quick Edit Bug

Gnappy As5A5sin
I couldn't edit a post I made in spam.

It just came up with the loading thing indefinitely.
I couldn't click on Save, Advanced, or Cancel, and ended up just refreshing the page and adding a new reply with my edit.

Seems to be working fine everywhere else I try to edit. In fact this is an edit now.

Running Chrome 15.0.874.121m on Windows XP SP3
On Skype Wolfpack Dragon wrote
"i came on the radio so I had to mention it"
Reply | Threaded
Open this post in threaded view
|

Re: Quick Edit Bug

GodlyPerfection
Administrator
Just got the issue myself in that same thread and a couple of other SP threads. However it seems to work fine in this thread and most other places I've tested.



URL: http://i55.tinypic.com/13yi6va.png

Wanna help spread the word about ReachingPerfection.com at other sites? Use the image above and link back to us.
Reply | Threaded
Open this post in threaded view
|

Re: Quick Edit Bug

DavidJCobb
Administrator
In reply to this post by Gnappy As5A5sin
I'll look into this. If either of you experience this bug again, check Chrome's error console (if possible), and post any JS errors for the forum that you see.

Also, the next forum update will make it so that "Cancel" aborts loading of posts, allowing you to forcibly retry to edit. I'll make a note for an appearance change as well -- the other buttons are disabled during loading, but the CSS doesn't make this apparent.
Reply | Threaded
Open this post in threaded view
|

Re: Quick Edit Bug

DavidJCobb
Administrator
This post was updated on .
In reply to this post by Gnappy As5A5sin
Fixed in Testing Perfection, and error handling for Quick Edit post-loading in general is improved as well. The cause for this bug was the single-quote in the post subject line.

Since editing posts is still possible when this bug occurs (open the Edit link in a new tab), I won't push all changes immediately unless Godly directs me to.
Reply | Threaded
Open this post in threaded view
|

Re: Quick Edit Bug

noklu
Administrator
there is another, rare, bug that I've come across when editing a post. Instead of appearing with my own words, the edit box appears with the entire nabble page's coding. I've no idea how to duplicate it.
The otters are coming with whiskers honed to razor blades.
Know this and fear.

Email me at xnoklu[at]gmail.com should you need to contact me.
Reply | Threaded
Open this post in threaded view
|

Re: Quick Edit Bug

DavidJCobb
Administrator
noklu wrote
there is another, rare, bug that I've come across when editing a post. Instead of appearing with my own words, the edit box appears with the entire nabble page's coding. I've no idea how to duplicate it.
I'm guessing that for some reason, an error is occurring, and the script is blindly interpreting that as edit text.

Does it happen consistently with certain posts, or in certain sections of the site (i.e. the admin-only area)? Can you link me to the posts you're trying to edit if it happens again? Can you e-mail me (link on my profile) the code that gets returned in the edit box? And what version of what browser are you on?