Tech Issue: Video Embed (Youtube) does not function properly.

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Tech Issue: Video Embed (Youtube) does not function properly.

Sash
Administrator
I hope this is an easy fix. Thanks a bunch in advance Cobb, for keeping this place running.

General complaint is that we simply cannot use the embed function. It's maybe an issue with not doing it right in the coding department of things or Youtube may have changed their Embed Code slightly, which is throwing the site's features off.

Thanks again for looking into this.
Light can be just as blinding as Darkness. Bring some Sunglasses.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

noklu
Administrator
This post was updated on .
Test embed.



...and edit in HTML.
The otters are coming with whiskers honed to razor blades.
Know this and fear.

Email me at xnoklu[at]gmail.com should you need to contact me.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

GodlyPerfection
Administrator
In reply to this post by Sash


URL: http://i55.tinypic.com/13yi6va.png

Wanna help spread the word about ReachingPerfection.com at other sites? Use the image above and link back to us.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

GodlyPerfection
Administrator
In reply to this post by Sash
You can apparently embed without the nabble_embed tag. Just by using making the post HTML format and the embed code.


URL: http://i55.tinypic.com/13yi6va.png

Wanna help spread the word about ReachingPerfection.com at other sites? Use the image above and link back to us.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

noklu
Administrator
In reply to this post by Sash
Right. I'll put the workaround up as a forum announcement.
The otters are coming with whiskers honed to razor blades.
Know this and fear.

Email me at xnoklu[at]gmail.com should you need to contact me.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

RPTestSubject
In reply to this post by Sash

Test for someone without Admin privileges. I can't remember if iframes are restricted, but it seems like they might be.

Edit: Nope, it works.

Rammer Spree!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

Sash
Administrator
RPTestSubject wrote
<p>Test for someone without Admin privileges.  I can't remember if iframes are restricted, but it seems like they might be.</p>
<p>Edit: Nope, it works.</p>

<iframe width="420" height="315" src="//www.youtube.com/embed/r6VCnYkNYLo" frameborder="0" allowfullscreen></iframe>
People have to learn HTML now. They will be confused as to why there are no Breaks in the paragraphs.

Good to see that it works though.
Light can be just as blinding as Darkness. Bring some Sunglasses.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

DavidJCobb
Administrator
In reply to this post by Sash
noklu, please remind me to do two things:

a. ask Nabble about this bug

b. consider changing BBCode to HTML button from regex-based to a parser if I can find a good one out there (I made one but am unsure of its quality)

Facebook or email reminders are preferred.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

Dj7291993
Administrator
In reply to this post by Sash
Yeah, they will have to learn the paragraph tag, but that will be sufficient for most of them.If they want to do more, they can.  But they'd only need to use it in the posts where they are embedding a video.

~Josh Hollinrake, Dj7291993

Email Me - Admin Message Box - My Portfolio

"Dreamers Dream, Doers Do, Achievers Achieve, But Champions Do It ALL." ~The Goads

"A man cannot directly choose his circumstances, but he can choose his thoughts, and so indirectly, yet surely, shape his circumstances." ~James Allen (As a Man Thinketh)

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

DavidJCobb
Administrator




Confirmed. Embed does not function if wrapped in Nabble tags, regardless of whether HTML is enabled. If unwrapped and put in an HTML-enabled post, it works.

I've inquired about the matter at Nabble Support.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tech Issue: Video Embed (Youtube) does not function properly.

DavidJCobb
Administrator
This post was updated on .
In reply to this post by Sash

The problem is a regex issue. If you modify the IFRAME's SRC and add an https: protocol to the URL, then it will match and the NABBLE_EMBED tag will work.

It seems like Nabble's been maintaining these regexes, so instead of fixing it with my own NAML override, I've informed them of the problem. Hopefully, it'll be fixed soon. In the meantime, just tack on that HTTP or HTTPS -- and keep it lowercase. The resulting code should look like the following:

<nabble_embed><iframe width="420" height="315" src="https://www.youtube.com/embed/ZEBGCOCxLgA" frameborder="0" allowfullscreen></iframe></nabble_embed>
Loading...